New member with a problem

Introduce yourself to the community. Tell us about yourself, what you ride, and share your favorite picture.
Post Reply
User avatar
Clutch93
New to XJR
New to XJR
Posts: 1
Joined: Sun May 14, 2017 1:23 am
Region or State: IL
Motorcycles Owned Currently: 1996 Yamaha xj600

New member with a problem

Post by Clutch93 » Sun May 14, 2017 10:07 am

Hey guys, just bought a 1996 xj600. I paid $300 for it being in rough shape. It ran when I bought it, but only enough to go for a little test ride. So far I have cleaned the carbs, got a new fuel filter and changed plugs. After doing that, the bike ran much better. Now I'm stuck at this point here. I bought the fuel filter yesterday (the one that was recommended from autozone that fits in the factory mount. All was well when I first installed it, I cracked the petcock open and fuel rushed into the clear filter as it should have. Went for a 20 min ride and once I got home the bike began to sputter and lean out and then died. I looked at the fuel filter and it was empty! I have half a tank of gas and the fuel is on. I took the tank off again and with the lines off I turned the petcock to the prime selection and gas pours out as it should and shuts off on reserve as it should. Once I put the filter back on though, it wont fill up, inturn not letting my bike get any gas to run. Please help!!! Sos!

User avatar
AlecJ
Lookin' Around
Lookin' Around
Posts: 34
Joined: Mon Jan 30, 2017 8:24 am
Region or State: South Africa
Motorcycles Owned Currently: 1999 XJ600N, TTR125S
Location: Upington

Re: New member with a problem

Post by AlecJ » Mon May 15, 2017 1:51 am

Check if your fuel pump is working, mine died soon after getting my bike ordered a new one from ebay

http://www.ebay.com/itm/12v-60-LPH-Fuel ... UA&vxp=mtr
I ride solo

North1987
Lookin' Around
Lookin' Around
Posts: 22
Joined: Tue Oct 04, 2016 2:48 pm
Region or State: Ontario, Canada
Motorcycles Owned Currently: 96 xj600

Re: New member with a problem

Post by North1987 » Mon May 15, 2017 10:24 am

Hey welcome to the site always nice to see a new member. When you have it on the bike and you turn it to the prime position do you get fuel? The only reason I ask is because it sounds to me your petcock check valve is stuck/ not working. Before we go down this path though it would be good to perform a quick test, with everything hooked up on the bike turn your fuel to the prime position. This will bypass the check valve in the petcock, confirming or eliminating the petcock check valve.

User avatar
radare
Site Founder
Site Founder
Posts: 8350
Joined: Mon Nov 07, 2011 12:42 pm
Region or State: Rocky Mountains
Motorcycles Owned Currently: '92 XJR600, '92 Seca II
Location: Denver, CO
Contact:

Re: New member with a problem

Post by radare » Mon May 15, 2017 12:19 pm

North1987 wrote:
Mon May 15, 2017 10:24 am
Hey welcome to the site always nice to see a new member. When you have it on the bike and you turn it to the prime position do you get fuel? The only reason I ask is because it sounds to me your petcock check valve is stuck/ not working. Before we go down this path though it would be good to perform a quick test, with everything hooked up on the bike turn your fuel to the prime position. This will bypass the check valve in the petcock, confirming or eliminating the petcock check valve.
Good advice there, North. And Clutch, welcome to the site.

User avatar
mikee112
User Administrator
User Administrator
Posts: 2032
Joined: Sun Mar 04, 2012 10:13 am
Region or State: UK
Motorcycles Owned Currently: '99 Yamaha XJ 600n
Location: Essex, England

Re: New member with a problem

Post by mikee112 » Mon May 15, 2017 12:26 pm

Hey Clutch, Welcome to the forum :)

Post Reply

Who is online

Users browsing this forum: No registered users